Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Can we have a function like this in UAK? I wrote this for Leadwerks to access the Window's Font Directory.

//-----------------------------------------------------------------------------
// Purpose:
//-----------------------------------------------------------------------------
std::string GetSystemEnviroment(const char* pszEnv)
{
#ifdef _WIN32
	return std::string(getenv(pszEnv));
#else
	// ????
#endif
	return "";
}

My use case:

//-----------------------------------------------------------------------------
// Purpose:
//-----------------------------------------------------------------------------
std::string GetSystemFontDir()
{
	std::string path = "Fonts/";
#ifdef _WIN32
	std::string syspath = GetSystemEnviroment("WINDIR");
	path = Leadwerks::FileSystem::RealPath(syspath);
	path = path + "/Fonts";
#else
	// Not sure what to do here for Linux.
	DMsg("STUBBED: System font loading for linux!");
#endif
	return path;
}

 

 

Link to post
Share on other sites
  • 2 weeks later...

Just wondering if we will be able to scale the GUI  like this. In UAK.

GUI Scaling in Blender3D

I am thinking of an app where you can maybe press

Shift+Ctrl and the + or - on numeric key pad to scale UI

or

Shift+Ctrl and the Middle mouse scroll wheel to scale UI

at any time you feel like scaling the UI.

Also will a version number be added soon to the UAK Hub. I am not sure what version I am using. Even though I believe it is still Beta?

Almost forgot, one of the things I really love in software is perhaps a link 'Check for updates' that would be cool.

 

Link to post
Share on other sites

DPI scaling is already supported. 😄 I am snowboarding now so I will write details later. You can descale at-will and it is totally resolution independent.

  • Like 2
Link to post
Share on other sites

Ultra App Kit is updated on Steam.

  • WINDOW_EMBEDDED is removed. Use WINDOW_CHILD instead.
  • All documentation examples should work now.
  • Moved all linker dependencies (except the main lib) into Framework.h so project setup is simpler.
  • Removed all header search paths except one.
  • All preprocessor definitions are removed except for _ULTRA_APPKIT.
  • Thanks 1
Link to post
Share on other sites

Just wondering does it update it's self, cause I never actually see any thing that say's 'Update'. Just always say's 'Launch'.

 

Just noticed in Steam Settings 'Always keep this Game Updated' so I guess it is Automatic.

Link to post
Share on other sites
24 minutes ago, Jules D. said:

Just wondering does it update it's self, cause I never actually see any thing that say's 'Update'. Just always say's 'Launch'.

 

Just noticed in Steam Settings 'Always keep this Game Updated' so I guess it is Automatic.

It will update automatically the next time you start Steam.

Link to post
Share on other sites

The project manager application now initializes Steamworks and contacts the server once for login authentication. The authentication token is locked pretty well to your machine, so it only needs to sign in once.

  • Like 1
Link to post
Share on other sites

UAK comes with an event class that will allow you to handle events for your window and interface, you can check that out here.

I've not looked into the event stuff quite yet but I'm sure its robust enough to do some cool stuff with (handling input for viewport cameras, etc).

Link to post
Share on other sites

Ok not going to lie, Yesterday was the first time I actually tried getting into C++ programming. With the UAK. Or any C++ period.  It always seemed scary to me. This may me due to my bad memory. Example I have been dealing with the computer since I was about 12. I am 52 now and to this day I still have to look at the keyboard to type. Not to mention never remembering what C++ commands there are.

 So managed to have the App look for theme pref file. If not, theme selector will pop up.  Then it will save your selected theme to preference file. Every time you run the App it will always load with the new selected Theme from the Menu as well.

https://youtu.be/lq__ddIkpfs

I am sure stuff like this is very simple for Josh.

But for my first time. I even made sure that errors would not occur such as App loading Prefs, but Prefs file is not there. It will create it.

Just trying to create a full theme system that can be transferred to other Created Apps.

And I also started a Theme Editor.

Just want to thank the Super Brilliant people such as Josh. For bringing stuff like this to other People.

C++ does not seem so Scary anymore.

I will be looking to clean it up a bit, such as One Prefs file for everything maybe in it's own folder, perhaps as a json file instead of txt. But text is so easy to work with.

Just one Question Is it possible to override the color of each button. For example with the 'fill' command? The reason is I want each button to match it's Properties theme color.

 

  • Like 2
Link to post
Share on other sites

Your video is set as "private" so I can't watch it!

6 minutes ago, Jules D. said:

Is it possible to override the color of each button. For example with the 'fill' command?

button->SetColor(1,0,0,1); :D

Link to post
Share on other sites
8 hours ago, Robert_d1968 said:

Where should the plugins be downloaded too?

Thanks,

Robert

The plugins are already available in the project "Plugins" folder.

  • Basis: Basis universal pixmap loader
  • FITextureLoader: FreeImage pixmap loading for most image formats.
  • ISPCTexComp: Fast pixmap conversion to BC7 texture format.
  • LELegacy: support for loading Leadwerks .tex images.
  • VTF: support for Valve texture format loading.
Link to post
Share on other sites

It seems there may be a bug with the debug fast link option within Visual Studio, each time you place a breakpoint to run and debug you get greeted with this error dialog:

IMAGE REMOVED

The default build settings in the generated project from the launcher has been set to fast link so you will always get this error message before running in debug mode. I'm not too sure why but to resolve this I have had to change from fast link to full generation of debug information (it might be a good idea to apply this change to newly generated projects created by the launcher as well).

I've created and built my own project (without the launcher) and the same thing happens in there and I've resolved it the same way I mentioned above. I'd like to point out that having this error message doesn't stop you from debugging, you can still see your data in the watcher and locals but it does popup every single time you go to run and debug. 

Link to post
Share on other sites
13 hours ago, SlipperyBrick said:

It seems there may be a bug with the debug fast link option within Visual Studio, each time you place a breakpoint to run and debug you get greeted with this error dialog:

I just tried it and it worked fine with fastlink enabled. :wacko:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...