Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Robert_d1968

Members
  • Content Count

    78
  • Joined

  • Last visited

Everything posted by Robert_d1968

  1. Cool, I want to try the linux version out, I'm running on Ubuntu Linux right now, can't wait for it to come out. Although steam does not seem to run on this version. Robert
  2. Robert_d1968

    Present Hunt

    What software was this created in? Robert
  3. Robert_d1968

    Present Hunt

    A very nice game, indeed. nicely laid out and fun to hunt all of those presents down. Robert
  4. I'm going to switch to Linux, I just can't stand Windows any longer. Will the newer platforms run under linux? Robert
  5. So now, my programs name is Ultra App Kit instead of Ultra Engine. Are you merging them? Robert PS. is there any game made with this as of yet? If so I would like to see some source code as I learn faster from that.
  6. Robert_d1968

    Texture.IO

    Cool, I can't wait to get my hands on that... Robert
  7. Robert_d1968

    Texture.IO

    How do I get this Texture.IO Program? is it out already? Robert
  8. I ran into that last night, it never caught me though... it's not fast enough. By the way, what version of leadwerks was this game made in? Robert
  9. I did purchase that game through steam for my son...
  10. What is with Visual C++? there is no object oriented window in the program that I can find... I about ready to create libraries in XOJO to support my programming in Xojo it is object oriented programming in ever aspect of it. This way I can make cool games with it. Robert
  11. Thank you sir, I shall try that out. should do me some good. Robert
  12. Hey, thank you for that code it did draw the Triangle as it should. But I did not notice a difference with the buttons, I will check it again.. Robert
  13. when I place the code here: while (true) { auto err = glGetError(); if (err != 0) Print(err); //Check for events const Event ev = WaitEvent(); switch (ev.id) { case EVENT_WINDOWPAINT: if (ev.source == subwindow) { iVec2 sz = subwindow->ClientSize(); glViewport(0, 0, sz.x, sz.y); glClearColor(0.15f, 0.15f, 0.15f, 1.0f); glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT); glBegin(GL_TRIA
  14. Not on the second window no, but on the first window I got a code of 1282 in the debug console. Robert
  15. This was the code from it: #include "UltraEngine.h" using namespace UltraEngine; #include <GL/GL.h> #pragma comment (lib, "opengl32.lib") bool ResizeViewport(const Event& ev, shared_ptr<Object> extra) { if (ev.id == EVENT_WINDOWSIZE) { auto window = ev.source->As<Window>(); iVec2 sz = window->ClientSize(); auto subwindow = extra->As<Window>(); subwindow->SetShape(200 + 1, 8 + 1, sz.x - 200 - 8 - 2, sz.y - 16 - 2); } return true; } int main(int argc, c
  16. Well, the first top half of the code produced a whit colored box. seems to be okay. But the second box from the code below produced a darker colored box, with three objects to be clicked on. No matter which one I clicked, nothing was drawn to the screen. Robert
  17. So if I want to try out the openGL project, Which is the correct one to use for the code to draw the triangle with colors? Robert
  18. Ok, I will try it out. Thank you very much for your help sir. Robert
  19. Okay, I will have a look see. Thanks for the help, Robert
  20. Where do they hide that on Steam? I have never seen templates on there. Robert
  21. "if you have the "inherit from project defaults..." option selected. So you are right, you must select the option "optimized for sharing blah blah blah..."." I can't seem to find the "inherit from project defaults..." option where is that located? Robert
  22. Thank you kind sir, I will give that a shot and see how it goes. Robert
  23. I'm just curious, as to the Win(32) unloaded as my system is 64 bit windows 10. It seems as if it is trying to load 32 bit instead of 64 bit, but debug is set to 64 bit and /Debug:FULL Robert
  24. I now have installed 16.9.2 of Visual C++ after I start debug and then stop, I get this code on the output.. Some things did not load. 'OpenGL1_d.exe' (Win32): Loaded 'C:\Users\Robert\Documents\Ultra Engine\Projects\OpenGL1\OpenGL1_d.exe'. Symbols loaded. 'OpenGL1_d.exe' (Win32): Loaded 'C:\Windows\System32\ntdll.dll'. 'OpenGL1_d.exe' (Win32): Loaded 'C:\Windows\System32\kernel32.dll'. 'OpenGL1_d.exe' (Win32): Loaded 'C:\Windows\System32\KernelBase.dll'. 'OpenGL1_d.exe' (Win32): Loaded 'C:\Windows\System32\user32.dll'. 'OpenGL1_d.exe' (Win32): Loaded 'C:\Windows\System3
×
×
  • Create New...