Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Installing Leadwerks for Linux


Recommended Posts

Kickstarter rewards are going out today! Here are instructions on how to get started.

 

System Requirements

  • Ubuntu 12.04 64-bit LTS.
  • Nvidia or ATI graphics card with support for OpenGL 4.0. (Intel didn't come through with GL4 support, so a 3.3 fallback will be added.)

 

Installing

Download the tar.gz file and extract the contents to any directory. I suggest using "~/Leadwerks".

 

There are two ways you can proceed.

 

The Easy Way

Run the Launcher executable. When prompted, enter your password to install required dependencies. (The launcher just checks to see if the Leadwerks config file exists, and runs "install.sh" if it does not, then runs Leadwerks.)

 

The Other Easy Way

Run the included install.sh script to install required dependencies, then run Leadwerks.

 

Your games made with Leadwerks only rely on the 64-bit "GL", "GLU", and "openal" libraries, so they can be installed very easily.

  • Upvote 1

My job is to make tools you love, with the features you want, and performance you can't live without.

Link to post
Share on other sites

 

Installing

Download the tar.gz file and extract the contents to any directory. I suggest using "/Home/Leadwerks".

 

 

wouldn't ~/Leadwerks (= /home/username/Leadwerks) make more sence as it doesn't require elevated privileges ?

  • Upvote 2

System:

Linux Mint 17 ( = Ubuntu 14.04 with cinnamon desktop ) Ubuntu 14.04, AMD HD 6850, i5 2500k

Link to post
Share on other sites

That's what I mean. In Nautilus, it is displayed as "Home", but yeah I mean the "~/" directory.

 

Leadwerks does not write to its own directory at any time, so you can place the package anywhere you want.

  • Upvote 1

My job is to make tools you love, with the features you want, and performance you can't live without.

Link to post
Share on other sites

I backed at the Pro Backer level, does it cover a Windows Standard version of Leadwerks?

 

PRO BACKER: Receive Leadwerks for Linux when it's released. This allows you to program games with C++ and Lua. You will also receive Leadwerks for Windows and Mac.
Link to post
Share on other sites

Yes, your password will work as a registration key. The Windows installer will be sent later this week.

  • Upvote 1

My job is to make tools you love, with the features you want, and performance you can't live without.

Link to post
Share on other sites

I know you support only Ubuntu but I am going to try to run it on openSUSE anyway, because it should work when given the right dependencies. However when I start "Leadworks" it creates a window in the middle of my two monitors (and I am not able to move it) with a message "Copying sample project" and the process is using 100% cpu with no meaningful console output. The window soon becomes broken as it will not refresh itself if overlapped by other windows. Any tips how to debug this problem?

Link to post
Share on other sites

The first time the application runs, it copies the sample project to ~/Documents/Leadwerks/Projects/MyGame. On my non-SSD it just takes about 20 seconds to copy the files, and it only does it the first time it runs.

My job is to make tools you love, with the features you want, and performance you can't live without.

Link to post
Share on other sites

I am using Ubuntu 14.04. I chose not to run install.sh as I don't like the look of those symlinks. I ran the launcher and when prompted for my password I ctrl+c'ed it. The app started fine (as I probably have all the necessary dependencies from other stuff I have installed), but did take a fair while to do the inital copy of the game project on my non-SSD. As I'd run Leadwerks from the command line I could see it was doing something but the main window was blank for the entire time, which probably would be alarming for some new user.

Link to post
Share on other sites

Josh, where are we to post bugs? I got a couple of things to report so far.

1. I launched the engine using the "launcher" executable and it didn't ask for my account/login info, it just went straight to the level editor.

2. WASD navigation is not working in the 3d viewport, nor is the middle mouse wheel to zoom in/out (but it works ok in the 2d viewports).

 

regards,

Alvaro

Win8.1 Pro X64/ Intel core I7 @ 3.5GHz / 32GB DDR3 SDRAM / GeForce GTX 660+760/ VC++ Express 2013/ Blender /Unwrap3dpro3 /Modo 8

Link to post
Share on other sites

A few bugs here as well:

  1. The install script messed up the package manager by trying to install "appmenu-gtk:i386", which on Ubuntu 13.10 has been replaced by "unity-gtk2-module:i386", which shouldn't be installed using the ":i386" postfix as it's platform independent. Solution: install "unity-gtk2-module" instead on Ubuntu 13.10.
     
  2. I was never asked for account/login info either, went straight to level editor.
     
  3. Trying to open any file selection dialog instantly crashes Leadwerks (e.g. File->Open or Project Manager->Import).
     
  4. Is the MyGame project supposed to be blank? Being unable to open anything I'm presented with an empty project that has the assets from the demo, but not any scenes.

 

Note: Leadwerks says it created a dump file on the crash, but I can't seem to find it.

Link to post
Share on other sites

A few bugs here as well:

  1. The install script messed up the package manager by trying to install "appmenu-gtk:i386", which on Ubuntu 13.10 has been replaced by "unity-gtk2-module:i386", which shouldn't be installed using the ":i386" postfix as it's platform independent. Solution: install "unity-gtk2-module" instead on Ubuntu 13.10.
     
  2. I was never asked for account/login info either, went straight to level editor.
     
  3. Trying to open any file selection dialog instantly crashes Leadwerks (e.g. File->Open or Project Manager->Import).
     
  4. Is the MyGame project supposed to be blank? Being unable to open anything I'm presented with an empty project that has the assets from the demo, but not any scenes.

Note: I can't seem to find the dump file.

Ubuntu 13.10 isn't supported, but someone has an alternative script in the Ubuntu forum. He also mentioned menu problems.

 

The MyGame example project has 8 example maps.

My job is to make tools you love, with the features you want, and performance you can't live without.

Link to post
Share on other sites

Ubuntu 13.10 isn't supported, but someone has an alternative script in the Ubuntu forum. He also mentioned menu problems.

Yes, the menu is in the application window instead of the global menu - not a big issue for me though.

The MyGame example project has 8 example maps.

I can see them in the file manager, but they don't show up in the editor.

Opening the folder from the right-click menu launches Nautilus btw, not my default file manager. You should probably call xdg-open instead of nautilus directly.

Link to post
Share on other sites

Got a trace this time: http://pastebin.com/jVRSAEbW

 

Also, running the MyGame project from its executable gives this error:

Loading map "/home/cybolic/Leadwerks/MyGame/Maps/start.map"...
Error: Failed to read file "/home/cybolic/Leadwerks/MyGame/Maps/start.map".

Now, changing the map in "MyGame/Scripts/App.lua" to "01-Introduction.map" lets the game run (shows a car - is that the demo?), but am I missing some files?

 

UPDATE: I've created new topics for these bugs in the Bug Reports section instead, as I should have done from the beginning.

Link to post
Share on other sites

I'm running arch, and I get this, then it crashes:

 

" Failed to initialize sound device. Is OpenAL installed? "

 

In the terminal:

"

ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

AL lib: (EE) alsa_open_playback: Could not open playback device 'default': No such device or address

Failed to initialize sound device. Is OpenAL installed?

"

 

Ubuntu is a horrible distribution, Arch users never have to run around trying to solve "package dependencies" or have to worry about downloading packages that are over a year out of date, or waste time trying to find ppas to appease that problem.

 

So I hope that we get some sort of fix soon, or maybe it just goes to show, that closed-source software doesn't really belong in the linux community.

Link to post
Share on other sites
[...] or maybe it just goes to show, that closed-source software doesn't really belong in the linux community.

 

There are closed source packages that work just fine - it all comes down to the persons preparing the packages.

System:

Linux Mint 17 ( = Ubuntu 14.04 with cinnamon desktop ) Ubuntu 14.04, AMD HD 6850, i5 2500k

Link to post
Share on other sites

I have a question, when Leadwerks will be updated, should download new version via the same link? I assume you'll be posting a change list on this site?

 

and, do you have any estimation on the OGL 3.3 fallback? I currently have Intel HD 4600 GPU and although this machine is pretty powerful - I'm not looking into buying new card soon, I'm waiting for the current gen cards price to drop so I can get one for lower price.

 

Having said that, if you estimate it can take some time, i'll get me a cheap card to meet the requirements.

Link to post
Share on other sites

Excellent, good to see its finally available! Unfortunately ...

 

 

velofille@ishtar:~/Leadwerks$ ./Launcher 
sh: 1: gnome-terminal: not found

Initializing OpenGL4 graphics driver...
OpenGL version 331
GLSL version 330
Device: ATI Mobility Radeon HD 4650
Error: OpenGL4 graphics driver is not supported.
Failed to initialize graphics.  Your graphics hardware may not be supported.

 

:(

time to upgrade!

Link to post
Share on other sites

that you need openGL 4 graphics is a old hat. and nope. it will never fallback.

 

you need openGL 4 grapics to create the game and you will need it to play. we live in 2014 now. opengl 4 was released 2010. if there would be a fallback you would missing a bunch of features. your game development also needs time. if your game ever be finished there will be maybe openGL 5 available.

 

you will also have no fun with openGL 3 graphics while creating 3d stuff (AAA)

It doesn´t work... why? mhmmm It works... why?

Link to post
Share on other sites

that you need openGL 4 graphics is a old hat. and nope. it will never fallback.

 

Except that Josh specifically wrote that he would do a fall back for intel, but don't let me disrupt your usual ignorance with mere facts.

  • Upvote 1

System:

Linux Mint 17 ( = Ubuntu 14.04 with cinnamon desktop ) Ubuntu 14.04, AMD HD 6850, i5 2500k

Link to post
Share on other sites

As I'd run Leadwerks from the command line I could see it was doing something but the main window was blank for the entire time, which probably would be alarming for some new user.

Maybe that's what is happening to me. I was not patient enough to wait for more than 3-4 minutes. @Josh - Shouldn't this window provide some kind of feedback?

Link to post
Share on other sites
Except that Josh specifically wrote that he would do a fall back for intel, but don't let me disrupt your usual ignorance with mere facts.

 

He also said that everything he said will be stupidly cut in stone. There is no OpenGL 3 support for now and to edit my quote. I dont wanted to get accross with ignorance if you guess this.

 

it will I dont believe that it will ever fallback.

 

where is the benefit in supporting older OpenGL Versions apart from supporting more gpu old hardware?

It doesn´t work... why? mhmmm It works... why?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...