Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Full screen no working 4.6 :(


Recommended Posts

2 hours ago, Yue said:

 

I have the problem, but I had to set the scale to 100% and move the scale of the gpu screen.  It's something to do with high-resolution monitors.  The test project works well at the top of the screen resolution but if I start to lower the resolution I see the following.  

 

image.thumb.png.27d323395cac55f4adf0bf920c198170.png

Do you have more than one monitor?

Link to post
Share on other sites

... and as I had stated previously, I had disabled my secondary monitor and the problem still persisted. 

However, if the secondary monitor (the non-4K monitor) is made the primary and screentest.exe is run, then full screen works perfectly on that monitor. So, the problem does not appear to be dual screen related (per se). However, it does seem to have something to do with the 4k monitor, though I have no idea why. 

Link to post
Share on other sites

I don't know if it's 4k, I guess you can tell by the maximum resolution of the monitor.  

The only thing I can think of is to do a test with another video game engine that uses OpenGL and see the results, so we can rule out a local error. 

image.png.2aa18faf2022baa934e6b0849f37c610.png

 

Link to post
Share on other sites

4K means around 4000 vertical resolution, and typically the screen is scaled up. I think the default is 150% on Windows, but I prefer 200% so everything is the same size as a 1920x1080 monitor (1080p)

  • Like 1
Link to post
Share on other sites
1 hour ago, Josh said:

4K means around 4000 vertical resolution

Actually, no. When the use terms like 2K and 4K, they are talking about HORIZONTAL resolution, not vertical. 

From a website:

"As things stand, the majority of 4K displays come with 3840 x 2160 pixel (4K UHDTV) resolution, which is exactly four times the pixel count of full HD displays (1920 x 1080 pixels). There are also 4096 x 2160 pixel (DCI 4K) displays for the film industry that are referred to as 4K displays."

  • Haha 1
Link to post
Share on other sites

Returning to the topic, the only way I see it here is the percentage of windows in my case 100% and it solves the problem, besides moving one or another parameter in the nvidia control.  Now, I will never publish a game, however the question is if any user of the game comes across this must be a nightmare to tell him to do one thing, to do the other.

Link to post
Share on other sites
1 minute ago, Yue said:

Returning to the topic, the only way I see it here is the percentage of windows in my case 100% and it solves the problem, besides moving one or another parameter in the nvidia control.  Now, I will never publish a game, however the question is if any user of the game comes across this must be a nightmare to tell him to do one thing, to do the other.

Yeah, but that doesn't fix it for me. If I change scaling from 125% to 100% then Leadwerks still does not go full screen on my primary monitor (when set to my 4K monitor). Messing with my Nvidia settings (so far) have not changed this, either.

  • Sad 1
Link to post
Share on other sites
9 minutes ago, tumira said:

Try to disable DSR in NVIDIA control panel if it is enabled ?

That's the stupidest feature ever. We already have MSAA which is much more efficient than supersampling.

  • Upvote 1
Link to post
Share on other sites
13 hours ago, tumira said:

Try to disable DSR in NVIDIA control panel if it is enabled ?

When I was testing, I activated that thing, and it didn't launch the executable in full screen, only from the Leadwerks editor.  So I turned it off and it worked correctly but it doesn't solve the problem. 
image.thumb.png.cbb16c0bc175acbe3f09905a0bb2a3e0.png


 

Link to post
Share on other sites
  • 4 weeks later...

After talking to @Argent Arts trying to figure out what was happening I managed to reproduce the problem.

I have two screens of the same model both set to a resolution of 1920x1080 (which is their native resolution) in which full screen works fine.

If I set one or both of these to a resolution below their native, the problem happens.

@Argent Arts is using two screens as well, but both are different models and have different native resolutions.  By setting the lower native resolution screen to the primary Leadwerks ran in full screen but only on that screen, not the bigger one.

 

I'm not sure how Leadwerks manages full-screen mode, but from what looks to be happening, it seems Leadwerks is using the correct resolution of the screen for it's window, but is somehow scaling the result down as if the screen was still using it's native resolution.

The scaling options for Windows 10 would also do this because it would scale it up to be different from the native as well.

I'm not positive but with the Issue of the Leadwerks window appearing off screen, probably relates to the difference between native and current resolutions too.

 

Is anyone else able to reproduce this problem by changing their screen resolution?

Link to post
Share on other sites
25 minutes ago, SpiderPig said:

Just had a thought and looked at it again, when Leadwerks runs it is actually changing the screens resolution back to native ;)

 

EDIT : I changed my primary screen to 1680x1050 and had two black bars on the sides due to the aspect ratio.  When Leadwerks ran these bars disappeared.

I don't know what to think anymore, I can't find a solution to that. 

By the way, are you using the Beta version? I can't upload fbx models to Leadwerks in the beta version.

Link to post
Share on other sites
  • Josh locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...