Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problems getting Ultra App to Build/Compile in Linux


Recommended Posts

It seems after getting the Linux version (Ubuntu 20.04, no Ubuntu 18.04) issue fixed, I've run into other new problems.

I started using VS Code (which was recommended by you) and I can't seem to get UltraEngine.h to be found and referenced, even when including the Include path to the SDK folder in steam by editing the c_ccp_properties.json file to get it to start looking in there.
 

So I switched IDE to Code::Blocks and got much further along, but now having issues with it in finding X11/Xmu/WinUtil.h when I try to build the sample. Got any ideas why this is the case?


Looking through my hard drive folders, I did find the X11/Xmu/WinUtil.h and it is installed from the libxmu-dev package in the /usr/include/X11/Xmu/ folder.
I am still in process to ask the Code:Blocks community for help, but they are doing a migration so everything is read only at the moment.  I can't post.

I also went on-line and didn't find anything useful. 

So I'm looking for some answers to help solve this basic issue.  Any suggestions on where to look and what to do? 

Link to post
Share on other sites

You should not have to set up the project yourself. If you create a new project from the app it should just work out of the box?

There is a makefile created in your project's folder. That controls where evreything is found. Maybe look in that?

Link to post
Share on other sites

I had to fix the Make file as it was looking for AppKit.o and could not find it due to an extra "/" and the missing string of "debug/" or "release/" in the path.

The project still has issues with UltraEngine.h in VS code.

 

Tried using Ubuntu 20.04 since you used it hoping that it would solve any hidden reasons, and I found Ubuntu 20.04 worse in many ways in trying to get things started and configured then Zorin OS 16.

 

I'm getting to the point where I think some manual setup instructions are needed encase the make file fails to do a proper setup while also helping in using other IDEs for developing software using Ultra App Kit.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...