Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

So i spent a full day in leadwerks engine, with tons of errors with fbx import, edges turned visible, model clean in 3ds max, i hidded those edges still same problem.

edges appears  in leadwerks !!!!

i exported in fbx , tested version from 2009  to fbx 2017 version, nothing change

SO i used the same fbx on others engine, also inside Game-Guru.... and you know what???

 

My fbx object is CLEAN!!!

no turned edge !

this is my result under leadwerks 

 

screenshot70.jpg

screenshot72.jpg

Link to post
Share on other sites

Here! is! your! model! in! several! other! modeling! programs!!! From left to right, 3dcoat, uu3d, hexagon.model.thumb.jpg.e16c7256fe535459eedbdc289e3079b0.jpg

The model has poor edge flows as shown by the banding. Now fortunately LE has a way fix poor modeling skills in the LE Model Editor. Open up model in the model editor, and click TOOLS>Calculate Normals... Try using the angular threshold option and lowering the angular tolerance to clean up the normals on the faces causing the banding.

model_fixed.jpg.a5b0eb2998a35424508c01eb625a4345.jpg

  • Like 3
Link to post
Share on other sites
2 hours ago, Nexerade said:

Calculating normals does indeed help with darken things, but for some reason leadwerks doesn't have holes in circle things. It has only half of lower.

Without posting the model, we can only guess what you are alluding to... holes in circle things? no idea what you are trying to describe. Post the model and what it is supposed to look like in your own post. Do not hijack this bug report with something unrelated to the OP's report.

Link to post
Share on other sites
12 hours ago, Nexerade said:

Calculating normals does indeed help with darken things, but for some reason leadwerks doesn't have holes in circle things. It has only half of lower.

image.png.ba478eeb9bb1c503fb79d744dd26f338.png

When I've seem this it is usually because the model has not been triangulated before import. In Blender stick triangulate in your stack and it will get applied on export - unless you modify default export options. 

Whilst I think you don't HAVE to do this it can help as otherwise the engine has to decide which way to triangulate a quad which I think can lead to problems sometimes if it decides differently to your 3D authoring program. 

Not really an expert but if you're having problems this may help.  If still problems maybe start a new thread on it.

 

  • Upvote 1
Link to post
Share on other sites
  • 1 year later...
  • Josh locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...