Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Linux Build Problem


Recommended Posts

I've updated the CodeBlocks project template and a new project will compile with no issues, but there is a problem linking to the Leadwerks precompiled library.  No linking error is shown, but every Leadwerks command the code calls gives an "undefined reference to function..." error.

Any idea why this is happening?  I just installed the latest version of CodeBlocks on Ubuntu 16.04.

Link to post
Share on other sites
  • 3 weeks later...

So, on virtual machine with latest ubuntu 16.04 and fresh instalation of steam, leadwerks + necessary libraries (libgl1-mesa-dev, libopenal-dev, libcurl4-gnutls-dev) i'm able build the sample project in CodeBlocks and in CodeLite (with some modifications) too...

But it looks I'm not able to build Leadwerks projects on Ubuntu 16.10 anymore and have to switch back to Ubuntu 16.04 :(

Link to post
Share on other sites
11 minutes ago, aiaf said:

I think sticking to the ubuntu lts version is best, that's my experience not doing intermediary updates anymore.

16.04 end of life is 2021 still getting updates.Next lts will be 18.04 on april.

Yes, i aggree, it's the best practise, I just didn't expect such problems with compilators... Today I will reinstall it, i have /home dir as separate partition so it will be piece of cake :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...