Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can not import FBX with Animations (aka Actions/Takes/etc.)

Recommended Posts

I am not able to import the the attached sample model with two animation (named MoveIt and MoveItAgain).

Other engines i have tried do not have any proble with the file.

The FBX format isa 2013 but i have tried it with all version down to 2009.


The model and the animations were made and exported with Modo 901 Indie.


Any ideas what the problem is?


Any help is appreciated!


Link to post
Share on other sites

Two possibilities to start:


1. Make sure you checked animation in your export window, if you have one. Just want to make sure.

2. Make sure you have set up everything properly in the editor - most notably the animation shader. Check out this section and the next one below it:


Link to post
Share on other sites

Thx for the answer. But it isn't a problem with the shaders, its the importer.

I am aware of animation shaders smile.png


The importer is buggy it seems, because neither Unity nor UE4 has a probnlem with the files smile.png


I would like use Leadwerks because from concept and using C++ it is my favorite for my next oproject smile.png

Link to post
Share on other sites

Are the animations not keyframes? Other than that I cannot say why it would not work as I don't use modo - I think forum member Roland uses it and has had success with importing, so maybe he can give some insight if he sees this.


In any case, I simply loaded the fbx into UU3D and re-saved as fbx and it works in LE when an animation shader is applied.


Link to post
Share on other sites

Hi commanderz,


I'm a Modo user too (801). Skinned animations do work. To export an animated rig you need to "bind" the skeleton to the mesh under the setup tab after that it creates a vertex weight map and you can paint vertex weights for deformation.


There is an import issue with the fbx export and Modo. Modo works in meters and LE works in cm. If you set the scale in Modo to export to 0.01 to convert meters to cm which this conversion dosen't work. Everything I export into LE I need to be scaled by 0.01 for correct size. I think Josh is looking into this.


There are few little quirks but all in all it should work.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...