Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Hello Leadwerks Forum,


I'm new here and I am aware that animations in fbx have been discussed ( a lot ) before in several threads but all the topics I found are not directly related to my problem. Trying and testing around for two days now makes me feel that I won't find an answer by myself.


I am using Softimage 2015 to create rigs and animations for models that I want to import to Leadwerks (3.4 Indie Version) . First I create a rig with bones for animating my mesh. Then I create a shadow rig (just null objects) and then envelope and weight the mesh to this shadow rig. After animating the bones I plot all transforms on the shadow rig (Every null has now a key with SRT on every Frame), remove my constrains and delete the original bones. The animation still works, the mesh follows the shadow rig. If I export this and open it in Modo or again in XSI, everything works just fine.




However, when I import it to Leadwerks and open the model editor, I see the timeline and the hierarchy, but no animation is showing up. Here the FBX Export Settings. Is there a preferred Version or is the actual 7.4 okay?




Does anyone have a clue whats going on? Am I missing something? I tried all versions and all kinds of different settings, nothing seems to work. There is always just the mdl with no applied transformations in the editor. I will appreciate any help.



Link to post
Share on other sites



good idea but all vertices have weights, I checked that. What I find strange is that LW3 receives animations in the second case (the man) but not in my other tests (like the one I posted first). It's basically the same technique, exported with the same settings. Are there any known specifications the Leadwerks input needs?

Link to post
Share on other sites



okay cool, I'll upload the models when I come home, thanks in advance. In the first setup I placed the bones by myself without mirroring, the second setup (the man) is just some automated Softimage process. I can't say what happens under the hood, but the rig doesn't have inverted scalings or something like this if you mean that.


Is it possible to import Collada dae aswell? I thought LW just supports fbx for importing geometry.

Link to post
Share on other sites

So, here we go:



The zip includes two fbx files. It's the same model, slightly different shadow rigs with animations, both don't work for me in LW but open fine in MODO and Softimage.


I really appreciate the help, getting my animated characters to Leadwerks is crucial for the personal project I started. Is there maybe another format that can be imported to LW or just fbx?

Link to post
Share on other sites

With further investigation I managed to create one scenario which seems to work. (Sorry for all these ugly rigs and animations, they are just fast setups for testing the workflow. )




Unfortunately I can only achieve this with the standard Softimage man and the auto biped setup. I analysed this and tried to recreate with the exact same properties, values, export settings et cetera but nothing seems to work properly. LW just receives no animation with all the tests I did.


I will try to find out what the important circumstances are that break the hole fbx workflow in Leadwerks, but I would appreciate any help, hint or user experience. I think its quiet strange that all of these work in other packages via fbx import but not in LW3.



Link to post
Share on other sites

I took a look at the wobbler02 file only and found your issue and I should have picked up on the issue quicker...


In Leadwerks have you created material and assigned to the model? Then in the material to use an animated shader? The folder is Shaders\Model\Animated\



As soon as I did that it started animating in the model editor.




Reading your first post again, I have never heard of the technique that you are using with a secondary rig, sounds more complicated than it needs to be, and could be opening yourself up to more issues, but whatever.



There used to be a GREAT tool in the model editor to show the skeleton, but it has since been removed which I think is strange as it was a vital tool to check your skeleton for any import problems. This is a prime example where it would be useful. If this tool was there you would have seen that the skeleton was animating.


Please Josh put the show skeleton option back in!!

  • Upvote 1
Link to post
Share on other sites



Thanks for pointing that out! I read about this material thing but thought that this is only important for the scene, not the model editor. Stupid me, and if I think about it, the standard softimage man comes with an applied material that was imported into LW and made it work. How could I have missed that? I feel so stupid right now ...


Thanks again, very kind!



I read this shadow rig thing is very common for exporting animations to game engines because Softimage has a very sophisticated rigging system which I think can not be exportet with fbx. But I will try if I could skip this to work with LW. That would indeed be more practical.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...