Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

3.2 Unable to save/overwrite updated maps


Recommended Posts

Howdy,

 

 

Yesterday I purchased Leadwerks form steam and this afternoon I was able to drive it for the first time. I want to say that I like the practicality of the editor though I am having trouble with finding what dose what and to see about using advanced features. That I know will come with time and experience.

 

 

However the first thing I would do is create a new project I can play with, break and reassemble. I am able to make the new project fine but when I go to save the new map I will get a error message that says "Unable to overwright file filepath/Leadwerks/Project File/Test Project/Maps/Test.map"

 

 

I have verified the game file in Steam and have reinstalled to no avail. This error will also appear when saving a tutorial file. So I doubt it is something Project related from my new file.

 

 

Thank you for your time

 

 

Gateway DX4860 WIn7 x64 Service Pack 1

Intel Core i3-2120 CPU @3.3GHz

6GB RAM

NvidaGeForceGTX 550 Ti

Link to post
Share on other sites

I have again reinstalled the engine and still can not save any file and now when I try to run debug I get the message that it can not overwrite the file (the temp file that auto generates) in order to open the map in the play window. And most times the whole thing just crashes to desktop.

Link to post
Share on other sites

Sounds like a permission problem - does it work if you run it as administrator?

 

Opening the folder on my drive I have tried to run as administrator and found that it will not start saying that I need to have Steam running. I do of course have steam running but now I see there is a disconnect between my install path and the steam client and the Leadwerks software.

 

 

 

What folder is the project located in?

 

I had it installed in a folder in my library called common that is my install directory for all my steam programs. I had done this to make it easier to access as the current path is rather deep in my directory. I will try going into my original path and launch it from there to see if the problem is resolved.

 

-----

When I try to run as admin I get a error saying "Cant instalize, please start steam" and that is even digging into the C:programfilesx86/steam/steamapps/common/LeadWerks/

 

The path of my new project is Docomunts/MyProject/NewGame

 

------

OK, I have now created new projects and deleted them in many different places. All to the same effect. I can not save any files or even run the debug program to test what I have done in that map to see if anything else is working. Could someone link me to something about pathing in LW to see what I am missing? It could me something with how win7x64 structures its files but now that I see I can not run any maps in debug save for the premade maps, and those only if they are not changed in anyway. I believe that it maybe something more to do with the editor itself.

 

 

@Josh, is there a way I can download this without steam? I will try till the end of the end of the week but if I can not get this resolved I will have to refund the program while I still can.

Link to post
Share on other sites

I have AVG Free running at this time, should I look at permissions or try reinstall with it off?

 

------

 

Just scanned the LeadWearks folder and got a number of "excluded file, not scanned" hits They are the Models, Tools, and vcredist files. I do not believe that it is doing anything to them though

Link to post
Share on other sites

You can't run a Steam game from the EXE, it has to be run from Steam. I believe Steam always launched in admin mode. If not, launching Steam in admin mode will launch all processes witht he same rights, I believe.

Link to post
Share on other sites

You can't run a Steam game from the EXE, it has to be run from Steam. I believe Steam always launched in admin mode. If not, launching Steam in admin mode will launch all processes witht he same rights, I believe.

 

Sorry so late in getting back, took a bout of sickness for a few days and not able to sit at my desk top.

 

Its strange but launching steam in admin mode seemed to work. Ive created a new project and saved the map. Now I can actually go about learning this engine. Thank you.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...