I'm finalizing the Ultra App Kit API, which is going to be the basis of the new engine's API. Naming commands themselves is always a bit of an art unto itself. Some things are named a certain way because it is common convention, like Stream::Seek() instead of Stream::SetPosition() and ACos() instead of ArcCosine().
Other times we have holdovers from old APIs or BASIC syntax like Stream::EOF() or String::Mid().
Should a class that has no SetSize() method use GetSize() or Size() for a me